SP-Studio Community Bug report

  • I also had this problem, WTH Happened? :???:

    QbY7M.png


    Freude, schöner Götterfunken,
    Tochter aus Elysium!
    Wir betreten feuertrunken,
    Himmlische dein Heiligtum!
    Deine zauber binden wieder
    Was die Mode streng geteilt;
    Alle Menschen werden Brüder,
    Wo dein saftner Flügel weilt!

  • I am not sure what happened... one part of the database was broken and I had to repair it. We had this problem on the old server, but it never happened since I moved to the new one. Let's hope it will not happen again.
    Fortunately this can be fixed quickly and no data is lost, it's just annoying.

  • janina, ive been having problems with the log me in everytime i go online thing, its not working i keep needing to log in.

  • This is because of the updates I am working on (I mentioned this here). I am sorry for the problems, but in a couple of days things will be back to normal :).


    If you are curious: I think the reason for the current login problem is the URL. The SP-Studio main page, the forum, the gallery and everything else is located on my server "planearium.de". The domain sp-studio.de leads to this server, but usually you do not notice this, because only the domain http://www.sp-studio.de is shown in your browser. But when I installed the forum & gallery I did not use the correct links in the main menu, that's why "http://www.planearium.de/sp-studio/forum/" was shown in the browser instead of "http://www.sp-studio.de/forum/". I correct this now, but I am not finished yet. The cookies which save your login data might be irritated. So when you cannot log in check the URL in your browser. It should work fine if you always use the old one (http://www.planearium.de/sp-studio/forum/), so maybe you should bookmark it until I am finished with the website updates.

  • FINALLY the menu is fixed now. So it should work and look in the forum and gallery the same way it works and looks on the rest of the website. This was a problem since the redesign of the front page.

  • Every time when i am logged in and i use the upper section of the page to change from gallery to forum and stuff. (the big blue text in the white square) I automaticly get logged out. It's quite annoying.

  • There should be an easy solution for this, just update your bookmark :).


    I guess you bookmarked the forum with the old URL (http://www.planearium.de/sp-studio/forum/). The new URL is http://www.sp-studio.de/forum/ . When you are logged in through the old URL and click on the menu, you get logged out, because the menu uses the new URL. That's why this happens to you.


    So try this: Log out, go to http://www.sp-studio.de/forum/ , bookmark this page and log in. Then it should work again.


    If you already use the new URL it might be a problem with the cookies. I changed some settings for this now and hope this helps.

  • Yes, we're aware of the issue and we're working to solve it. Part of the problem is that the Moderators don't have the ability to delete comments made in Users' Personal Galleries, so they can only be deleted by the creator of the image.

  • Sadly i have a huge bug to report. When i rotate stuff and move it and i do the same for the other. I can't remove the other stuff, change color and so on. The only way i can remove it is to remove everything...

  • I try to duplicate the error, but I must do something wrong. This is what I tried to test it:


    1) I add a basketball
    2) I add a purse
    3) I rotate the ball and move it
    4) I rotate the purse and move it
    5) I can still remove both


    Did you do anything different? Or maybe the error only appears with some items. Do you remember which you used?


  • I guess it is on some items. I used the abe lincon kinda beard.

  • Indeed, the beards had an old setting I forgot to change. Now I checked all of them and replaced them, so it should work. I hope they were the only items with this problem.

  • The move tool doesn't work with the hats.


    The rotation tool doesn't work with the make up + extra body parts, the glasses and masks, weapons, the shirts and legs and feet… if this is intended? if so you should remove the menu options.

  • This sounds like you still get the old files. Do you see the new item menu all the time? If the old item menu shows up this is a clear sign that an old file is in your browser cache.


    But if you see the new item menu this should not happen. I will look into it, but right now this error does not happen to me.

  • Actually, Jareen's bug also occured to me, especially the hats and beards......

    QbY7M.png


    Freude, schöner Götterfunken,
    Tochter aus Elysium!
    Wir betreten feuertrunken,
    Himmlische dein Heiligtum!
    Deine zauber binden wieder
    Was die Mode streng geteilt;
    Alle Menschen werden Brüder,
    Wo dein saftner Flügel weilt!

  • Jareen's bug for the beards should be fixed, do you still get it now? I will check the hats as well.


    The hats look fine. But perhaps there are just single files which do not work. Do you remember which hats you tested?

  • I'll check it, also the kite shield, and some other items can't be rotated in certain angles:



    The shield should be facing straight upward, but it just snap like that.



    EDIT: The Beards work fine, and it seems only the crowns, one that's in my picture, and the Kingly red one don't work. Sometimes it does, sometimes it doesn't, especially after adding, and then moving another object.....

    QbY7M.png


    Freude, schöner Götterfunken,
    Tochter aus Elysium!
    Wir betreten feuertrunken,
    Himmlische dein Heiligtum!
    Deine zauber binden wieder
    Was die Mode streng geteilt;
    Alle Menschen werden Brüder,
    Wo dein saftner Flügel weilt!